1032 Sharing
分数 25
作者 CHEN, Yue
单位 浙江大学
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading
and being
are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i
in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress
is the position of the node, Data
is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next
is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1
instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
文章来源:https://www.toymoban.com/news/detail-437547.html
* 寻找有相同后缀的第一个字符位置,如果没有相同后缀,则输出-1;
*
* 使用静态数组代替链表。
*
* 先各自遍历两个链表,将其所有出现元素的下标记录在hs数组中,每出现一次,对应的元素加一,
* 最后遍历其中一个链表的元素,查看hs数组中的值,如果对应的值等于2,则为答案。文章来源地址https://www.toymoban.com/news/detail-437547.html
/**
* 寻找有相同后缀的第一个字符位置,如果没有相同后缀,则输出-1;
*
* 使用静态数组代替链表。
*
* 先各自遍历两个链表,将其所有出现元素的下标记录在hs数组中,每出现一次,对应的元素加一,
* 最后遍历其中一个链表的元素,查看hs数组中的值,如果对应的值等于2,则为答案。
*/
#include <iostream>
using namespace std;
struct Node
{
int add, nex;
char ch;
};
const int N = 1e5+10;
struct Node a[N];
int hs[N];
int h1, h2, n;
void Read()
{
cin >> h1 >> h2 >> n;
for(int i=0; i<n; ++i)
{
char ch;
int add, nex;
cin >> add >> ch >> nex;
a[add] = {add, nex, ch};
}
}
int main()
{
Read();
int temp = h1;
while(temp != -1)
{
hs[temp]++;
temp = a[temp].nex;
}
temp = h2;
while(temp != -1)
{
hs[temp]++;
temp = a[temp].nex;
}
int res = -1;
while(h1 != -1)
{
if(hs[h1] == 2)
{
res = h1;
break;
}
h1 = a[h1].nex;
}
if(res != -1)
printf("%05d\n", res);
else printf("%d\n", -1);
return 0;
}
到了这里,关于PAT A1032 Sharing的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!