分数 25
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:
-
The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
-
All the people in the rear row must be no shorter than anyone standing in the front rows;
-
In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
-
In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
-
When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.
Now given the information of a group of people, you are supposed to write a program to output their formation.
Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers N (≤104), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).
Output Specification:
For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.
Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
题目分析:
Bob Tom Joe Nick 175 188 190 186
Ann Mike Eva 168 170 168
Tim Amy John 160 160 159
题目所给的排列顺序是观众面对舞台,假设观众在很高的地方观看,从上往下看的视角所看到的排列顺序。
从观众视角进行排序,这里以最后一排为第一排,先把最高的人入队(若一样高则入队字典序排前的),然后左边站一个人,右边站一个人,排完一排再排下一排文章来源:https://www.toymoban.com/news/detail-471883.html
#include<bits/stdc++.h>
using namespace std;
const int N=10010;
int n,k;
struct people{
string name;
int height;
}p[N];
bool cmp(people a,people b){//按身高从大到小排序,相同身高按字典序排序
return a.height!=b.height?a.height>b.height: a.name<b.name;
}
int main(){
cin>>n>>k;
for(int i=0;i<n;i++)cin>>p[i].name>>p[i].height;//输入
sort(p,p+n,cmp);//排序
deque<string>q[k+1];//双端队列
int extra=n%k,rownum=(n-extra)/k;//extra表示多余人数,rownum表示除了最后一个排的每排人数
int cur;//记录当前是第几个人
for(cur=0;cur<rownum+extra;cur++){//将最后一排视作第一排,先插到队列里
if(cur%2==0)q[1].push_back(p[cur].name);//按照第一个在队尾入队,第二个在队头入队的顺序入队,交替队尾队头的入队
else q[1].push_front(p[cur].name);
}
for(int row=2;row<=k;row++){//从第二排开始插入
int cnt=0;//记录当前排插入的人数
while(cnt<rownum){//人数小于该排能插入的人数则循环
if(cnt%2==0)q[row].push_back(p[cur++].name);//同第一排的插法
else q[row].push_front(p[cur++].name);
cnt++;//每次插完该排人数+1
}
}
for(int i=1;i<=k;i++){//遍历k排进行输出
int flag=0;//用来防止行末空格
for(auto it:q[i]){//对于第i排
if(flag==0)flag=1,cout<<it;//第一个人都是直接输出
else cout<<' '<<it;//后面的每个人都要先输出个空格
}
cout<<endl;//一排输完后输出回车
}
return 0;
}文章来源地址https://www.toymoban.com/news/detail-471883.html
到了这里,关于1109 Group Photo(40行代码+超详细注释+题目分析,双端队列实现)的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!