分数 25
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.
After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.
Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes
if the two birds belong to the same tree, or No
if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
代码长度限制
16 KB
时间限制
150 ms
内存限制
64 MB文章来源:https://www.toymoban.com/news/detail-475803.html
#include<bits/stdc++.h>
using namespace std;
const int N=10010;
int n,k,bird,exist[N],q,a,b,cnt[N],Max,p[N];
unordered_map<int,int>mp;
int find(int x){//并查集找根结点的经典操作
if(p[x]!=x)p[x]=find(p[x]);
return p[x];
}
int main(){
cin>>n;
for(int i=1;i<=N;i++)p[i]=i;//初始化并查集
for(int i=0;i<n;i++){
cin>>k;
vector<int>v;
for(int j=0;j<k;j++){
cin>>bird;
v.push_back(bird);//输入鸟
exist[bird]=1;//出现过的鸟置为1
}
for(int j=1;j<k;j++)//将该照片里的鸟都合并到第一个鸟上
p[find(v[j])]=find(v[0]);
}
int pos=1;
while(exist[pos])pos++;//获得总共鸟的数量
for(int i=1;i<pos;i++)mp[find(i)]=1;//获得集合数量
cout<<mp.size()<<' '<<pos-1<<endl;//输出集合数量和鸟数
cin>>q;
for(int j=0;j<q;j++){
cin>>a>>b;
if(find(a)==find(b))puts("Yes");//若在一个集合
else puts("No"); //若不在一个集合
}
return 0;
}文章来源地址https://www.toymoban.com/news/detail-475803.html
到了这里,关于1118 Birds in Forest(35行代码+详细注释)的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!