题目内容:
编写函数,求给定字符串中数字字符的个数,在主函数中输入字符串及输出统计的个数。
输入格式:
%s
输出格式:
%d
输入样例:
abc123fg
输出样例:
3文章来源:https://www.toymoban.com/news/detail-509329.html
时间限制:500ms内存限制:32000kb文章来源地址https://www.toymoban.com/news/detail-509329.html
#include <stdio.h>
#include <string.h>
int count_digits(char *str) {
int count = 0;
for (int i = 0; i < strlen(str); i++) {
if (str[i] >= '0' && str[i] <= '9') {
count++;
}
}
return count;
}
int main() {
char str[100];
scanf("%s", str);
int count = count_digits(str);
printf("%d\n", count);
return 0;
}
到了这里,关于C语言程序设计:编写函数,统计字符串中数字字符的个数的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!