Packet Tracer - 使用思科 IOS 配置 DHCP
地址分配表
设备 |
接口 |
IPv4 地址 |
子网掩码 |
默认网关 |
R1 |
G0/0 |
192.168.10.1 |
255.255.255.0 |
不适用 |
S0/0/0 |
10.1.1.1 |
255.255.255.252 |
不适用 |
|
R2 |
G0/0 |
192.168.20.1 |
255.255.255.0 |
不适用 |
G0/1 |
已分配 DHCP |
已分配 DHCP |
不适用 |
|
S0/0/0 |
10.1.1.2 |
255.255.255.252 |
不适用 |
|
S0/0/1 |
10.2.2.2 |
255.255.255.252 |
不适用 |
|
R3 |
G0/0 |
192.168.30.1 |
255.255.255.0 |
不适用 |
S0/0/1 |
10.2.2.1 |
255.255.255.0 |
不适用 |
|
PC1 |
NIC |
已分配 DHCP |
已分配 DHCP |
已分配 DHCP |
PC2 |
NIC |
已分配 DHCP |
已分配 DHCP |
已分配 DHCP |
DNS 服务器 |
NIC |
192.168.20.254 |
255.255.255.0 |
192.168.20.1 |
目标
第 1 部分:将路由器配置为 DHCP 服务器
第 2 部分:配置 DHCP 中继
第 3 部分:将路由器配置为 DHCP 客户端
第 4 部分:验证 DHCP 和连接
拓扑图
场景
专用 DHCP 服务器可进行扩展,而且比较容易管理,但是在网络中的每个位置都部署一台服务器的成本可能会很高。而思科路由器则可配置为在不需要专用服务器的情况下提供 DHCP 服务。作为公司的网络技术人员,您的任务就是将思科路由器配置为 DHCP 服务器,为网络上的客户端提供动态地址分配。您还需要将边缘路由器配置为 DHCP 客户端,使它能够从 ISP 网络接收 IP 地址。
第 1 部分: 将路由器配置为 DHCP 服务器
步骤 1: 配置排除的 IPv4 地址。
配置 R2 从 R1 LAN 和 R3 LAN 中排除前 10 个地址。DHCP 地址池中的所有其他地址都应该可用。
R2(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R2(config)#ip dhcp excluded-address 192.168.30.1 192.168.30.10
步骤 2: 在 R2 上创建用于 R1 局域网的 DHCP 池。
- 创建名为 R1-LAN 的 DHCP池(区分大小写)。
R2(config)#ip dhcp pool R1-LAN
- 配置 DHCP 池以包括 DNS 服务器的网络地址、默认网关和 IP 地址。
R2(dhcp-config)#network 192.168.10.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.10.1
R2(dhcp-config)# dns-server 192.168.20.254
步骤 3: 在 R2 上创建用于 R3 局域网的 DHCP 池。
- 创建名为 R3-LAN 的 DHCP 池(区分大小写)。
R2(dhcp-config)#ip dh pool R3-LAN
- 配置 DHCP 池以包括 DNS 服务器的网络地址、默认网关和 IP 地址。
R2(dhcp-config)#network 192.168.30.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.30.1
R2(dhcp-config)#dns-server 192.168.20.254
第 2 部分: 配置 DHCP 中继
步骤 1: 配置 R1 和 R3 作为 DHCP 中继代理。
//R1
R1(config)#interface g0/0
R1(config-if)#ip helper-address 10.1.1.2
//R3
R3(config)#interface g0/0
R3(config-if)#ip helper-address 10.2.2.2
步骤 2: 设置 PC1 和 PC2 从 DHCP 接收 IP 编址信息。
第 3 部分: 配置 R2 作为 DHCP 客户端
- 配置 R2 上的千兆以太网 0/1 接口从 DHCP 接收 IP 编址,并激活该接口。
R2(config)#interface g0/1
R2(config-if)#ip address dhcp
R2(config-if)#no shutdown
注:使用 Packet Tracer 的加快转发时间功能可加快进程,或等到 R2 与 ISP 路由器建立 EIGRP 邻接关系。
- 使用 show ip interface brief 命令验证 R2 是否从 DHCP 收到了 IP 地址。
R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.20.1 YES manual up up
GigabitEthernet0/1 209.165.200.231 YES DHCP up up
Serial0/0/0 10.1.1.2 YES manual up up
Serial0/0/1 10.2.2.2 YES manual up up
Serial0/1/0 unassigned YES unset down down
Serial0/1/1 unassigned YES unset down down
Vlan1 unassigned YES unset administratively down down
R2#
第 4 部分: 验证 DHCP 和连接
步骤 1: 验证 DHCP 绑定。
R2#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.10.11 0002.4AA5.1470 -- Automatic
192.168.30.11 0004.9A97.2535 -- Automatic
R2#
步骤 2: 验证配置。
验证 PC1 和 PC2 现在是否可以 ping 通彼此以及其他所有设备。
【实验详细步骤】
//R2
R2>en
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R2(config)#ip dhcp excluded-address 192.168.30.1 192.168.30.10
R2(config)#ip dhcp pool R1-LAN
R2(dhcp-config)#network 192.168.10.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.10.1
R2(dhcp-config)# dns-server 192.168.20.254
R2(dhcp-config)#ip dh pool R3-LAN
R2(dhcp-config)#network 192.168.30.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.30.1
R2(dhcp-config)#dns-server 192.168.20.254
R2(dhcp-config)#exit
R2(config)#interface g0/1
R2(config-if)#ip address dhcp
R2(config-if)#no shutdown
R2(config-if)#end
R2#write
Building configuration...
[OK]
//R1
R1>enable
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface g0/0
R1(config-if)#ip helper-address 10.1.1.2
R1(config-if)#end
R1#write
Building configuration...
[OK]
//R3
R3>enable
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#interface g0/0
R3(config-if)#ip helper-address 10.2.2.2
R3(config-if)#end
R3#write
Building configuration...
[OK]
【实验脚本】
//R2
en
conf t
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp pool R1-LAN
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.20.254
ip dh pool R3-LAN
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 192.168.20.254
exit
interface g0/1
ip address dhcp
no shutdown
end
write
//R1
enable
conf t
interface g0/0
ip helper-address 10.1.1.2
end
write
//R3
enable
conf t
interface g0/0
ip helper-address 10.2.2.2
end
write
【实验链接】
链接:https://pan.baidu.com/s/1KJjpNf-8SWCIEOTZAn3iLA?pwd=8133
提取码:8133
--来自百度网盘超级会员V3的分享
【知识点】
这个实验涵盖了以下几个知识点:
- DHCP(动态主机配置协议):实验中涉及了DHCP服务器和DHCP客户端的配置。DHCP是一种用于自动分配IP地址、子网掩码、默认网关和其他网络配置信息的协议。
- DHCP服务器配置:实验中将思科路由器配置为DHCP服务器,为网络上的客户端提供动态地址分配。配置内容包括排除地址、创建DHCP池、指定网络地址、默认网关和DNS服务器地址。
- DHCP中继:实验中配置了DHCP中继代理,允许路由器接收DHCP请求并转发到指定的DHCP服务器。通过配置辅助IP地址,可以在多个网络之间传递DHCP消息。
- IP地址排除:在DHCP服务器配置中,使用"ip dhcp excluded-address"命令排除一定范围的IP地址,确保这些地址不会被分配给DHCP客户端。
- DHCP绑定:通过"show ip dhcp binding"命令可以查看DHCP服务器上已经分配的IP地址与相应客户端MAC地址的绑定关系。
- 配置路由器接口:在实验中,通过配置路由器的接口,如GigabitEthernet接口和Serial接口,来连接网络和配置相关参数。
- 网络连通性验证:通过使用ping命令,验证PC1和PC2之间的连通性以及与其他设备的连通性。
综上所述,该实验涉及到DHCP服务器和客户端的配置、DHCP中继代理的设置、IP地址排除、DHCP绑定的查看和网络连通性验证等知识点。通过这个实验,可以加深对DHCP协议和相关配置的理解,并掌握在思科路由器上配置DHCP的技能。文章来源:https://www.toymoban.com/news/detail-546997.html
成为一个出色的网络技术人员需要不断学习和实践,这个实验是你成长的一部分,相信自己,你能够克服困难!文章来源地址https://www.toymoban.com/news/detail-546997.html
到了这里,关于Packet Tracer - 使用思科 IOS 配置 DHCP的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!