输入一个 n 行 m 列的整数矩阵,再输入 q 个操作,每个操作包含五个整数 x1,y1,x2,y2,c,其中 (x1,y1) 和 (x2,y2) 表示一个子矩阵的左上角坐标和右下角坐标。
每个操作都要将选中的子矩阵中的每个元素的值加上 c。
请你将进行完所有操作后的矩阵输出。
输入格式
第一行包含整数 n,m,q。
接下来 n 行,每行包含 m 个整数,表示整数矩阵。
接下来 q 行,每行包含 5 个整数 x1,y1,x2,y2,c表示一个操作。
输出格式
共 n 行,每行 m 个整数,表示所有操作进行完毕后的最终矩阵。
数据范围
1≤n,m≤1000
1≤q≤100000
1≤x1≤x2≤n
1≤y1≤y2≤m
−1000≤c≤1000
−1000≤矩阵内元素的值≤1000
输入样例:
3 4 3
1 2 2 1
3 2 2 1
1 1 1 1
1 1 2 2 1
1 3 2 3 2
3 1 3 4 1
输出样例:
2 3 4 1
4 3 4 1
2 2 2 2
代码如下:文章来源:https://www.toymoban.com/news/detail-600353.html
#include <iostream>
#include <vector>
using namespace std;
const int N = 1010;
int n, m, q;
int l1, r1, l2, r2, v;
vector<vector<int>> nums(N, vector<int>(N, 0));
void insert(int l1, int r1, int l2, int r2, int c){
nums[l1][r1] += c;
nums[l2 + 1][r1] -= c;
nums[l1][r2 + 1] -= c;
nums[l2 + 1][r2 + 1] += c;
}
int main(){
cin >> n >> m >> q;
for(int i = 1; i <= n; i++){
for(int j = 1; j <= m; j++){
int c = 0;
cin >> c;
insert(i, j, i, j, c);
}
}
while(q--){
cin >> l1 >> r1 >> l2 >> r2 >> v;
insert(l1, r1, l2, r2, v);
}
for(int i = 1; i <= n; i++){
for(int j = 1; j <= m; j++){
nums[i][j] += nums[i - 1][j] + nums[i][j - 1] - nums[i - 1][j - 1];
}
}
for(int i = 1; i <= n; i++){
for(int j = 1; j <= m; j++){
cout << nums[i][j] << " ";
}
puts(" ");
}
return 0;
}
文章来源地址https://www.toymoban.com/news/detail-600353.html
到了这里,关于每日打卡day9——差分矩阵的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!