1184: 平面点排序(二)(结构体专题)
题目描述
平面上有n个点,坐标均为整数。横坐标相同时按纵坐标排序,否则按横坐标排序。本题要求用结构体存储坐标,再进行排序。先升序排序输出,再降序排序输出,可以自己写排序函数,也可以用qsort库函数排序。
输入
第一行是整数 n ( 1 < = n < = 100 ) n(1<=n<=100) n(1<=n<=100) ,表示接下来有 n n n 行,每行两个整数,表示平面上一个点的坐标。文章来源:https://www.toymoban.com/news/detail-609712.html
输出
输出有两行,即排序后的点,格式为 ( u , v ) (u,v) (u,v) ,每个点后有一个空格。第一行升序排序结果,第二行降序排序结果。文章来源地址https://www.toymoban.com/news/detail-609712.html
样例输入 Copy
4
1 3
2 5
1 4
4 1
样例输出 Copy
(1,3) (1,4) (2,5) (4,1)
(4,1) (2,5) (1,4) (1,3)
import java.util.Arrays;
import java.util.Scanner;
class Node implements Comparable<Node> {
int x, y;
public int compareTo(Node a) {
if (this.x != a.x) return this.x - a.x;
return this.y - a.y;
}
}
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
Node[] a = new Node[n];
for (int i = 0; i < n; i++)
a[i] = new Node();
for (int i = 0; i < n; i++) {
a[i].x = sc.nextInt();
a[i].y = sc.nextInt();
}
Arrays.sort(a, 0, n);
for (int i = 0; i < n; i++)
System.out.print("(" + a[i].x + "," + a[i].y + ") ");
System.out.println();
for (int i = n - 1; i >= 0; i--)
System.out.print("(" + a[i].x + "," + a[i].y + ") ");
}
}
到了这里,关于ZZULIOJ 1184: 平面点排序(二)(结构体专题),Java的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!