题目来源:http://noi.openjudge.cn/ch0101/08
08 字符三角形
总时间限制: 1000ms
内存限制: 65536kB
问题描述
给定一个字符,用它构造一个底边长5个字符,高3个字符的等腰字符三角形。
输入
输入只有一行, 包含一个字符。文章来源:https://www.toymoban.com/news/detail-694932.html
输出
该字符构成的等腰三角形,底边长5个字符,高3个字符。文章来源地址https://www.toymoban.com/news/detail-694932.html
样例输入
*
样例输出
*
***
*****
正确答案
#include<stdio.h>
int main()
{
char s;
scanf("%c", &s);
printf(" %c \n", s);
printf(" %c%c%c \n", s, s, s);
printf("%c%c%c%c%c\n", s, s, s, s, s);
return 0;
}
*
*
***
*****
到了这里,关于【C语言每日一题】08. 字符三角形的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!