实验拓扑
需求
1 R6为ISP只能配置IP地址,R1-R5的环回为私有网段
2 R1/4/5为全连的MGRE结构,R1/2/3为星型的拓扑结构,R1为中心站点
3 所有私有网段可以互相通讯,私有网段使用OSPF完成。
IP规划
配置IP
R1
#
interface GigabitEthernet0/0/0
ip address 16.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 61.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.1.1 255.255.255.0
#
R2
#
interface GigabitEthernet0/0/0
ip address 26.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.2.1 255.255.255.0
#
R3
#
interface GigabitEthernet0/0/0
ip address 36.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.3.1 255.255.255.0
#
R4
#
interface GigabitEthernet0/0/0
ip address 46.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.4.1 255.255.255.0
#
R5
#
interface GigabitEthernet0/0/0
ip address 56.1.1.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.5.1 255.255.255.0
#
R6
#
interface GigabitEthernet0/0/0
ip address 16.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 61.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 56.1.1.2 255.255.255.0
#
interface GigabitEthernet2/0/0
ip address 26.1.1.2 255.255.255.0
#
interface GigabitEthernet3/0/0
ip address 36.1.1.2 255.255.255.0
#
interface GigabitEthernet4/0/0
ip address 46.1.1.2 255.255.255.0
#
配置缺省路由
R1
#
ip route-static 0.0.0.0 0.0.0.0 16.1.1.2
ip route-static 0.0.0.0 0.0.0.0 61.1.1.2
#
R2
#
ip route-static 0.0.0.0 0.0.0.0 26.1.1.2
#
R3
#
ip route-static 0.0.0.0 0.0.0.0 36.1.1.2
#
R4
#
ip route-static 0.0.0.0 0.0.0.0 46.1.1.2
#
R5
#
ip route-static 0.0.0.0 0.0.0.0 56.1.1.2
#
配置完成后测试各直连路由连通性
R1-R2R3的GRE环境配置
R1
#
interface Tunnel0/0/0
ip address 10.1.1.1 255.255.255.0
tunnel-protocol gre p2mp
source 16.1.1.1
nhrp entry multicast dynamic
nhrp network-id 100
#
R2
#
interface Tunnel0/0/0
ip address 10.1.1.2 255.255.255.0
tunnel-protocol gre p2mp
source GigabitEthernet0/0/0
ospf dr-priority 0
nhrp network-id 100
nhrp entry 10.1.1.1 16.1.1.1 register
#
R3
#
interface Tunnel0/0/0
ip address 10.1.1.3 255.255.255.0
tunnel-protocol gre p2mp
source GigabitEthernet0/0/0
ospf dr-priority 0
nhrp network-id 100
nhrp entry 10.1.1.1 16.1.1.1 register
#
配置完成后测试tunnel隧道的连通性
R1-R4R5的MGRE环境配置
R1
#
interface Tunnel0/0/1
ip address 10.1.2.1 255.255.255.0
tunnel-protocol gre p2mp
source 61.1.1.1
nhrp entry multicast dynamic
#
R4
#
interface Tunnel0/0/0
ip address 10.1.2.2 255.255.255.0
tunnel-protocol gre p2mp
source 46.1.1.1
nhrp entry 10.1.2.1 61.1.1.1 register
nhrp entry 10.1.2.3 56.1.1.1 register
#
R5
#
interface Tunnel0/0/0
ip address 10.1.2.3 255.255.255.0
tunnel-protocol gre p2mp
source 56.1.1.1
nhrp entry multicast dynamic
nhrp entry 10.1.2.1 61.1.1.1 register
#
配置完成后测试tunnel隧道的连通性
配置OSPF
R1的配置
#
ospf 1 router-id 1.1.1.1
area 0.0.0.0
network 10.1.1.1 0.0.0.0
network 10.1.2.1 0.0.0.0
network 192.168.1.1 0.0.0.0
#
#
interface Tunnel0/0/0
ospf network-type broadcast
#
GRE环境下的OSPF
文章来源:https://www.toymoban.com/news/detail-717725.html
R2
#
ospf 1 router-id 2.2.2.2
area 0.0.0.0
network 10.1.1.2 0.0.0.0
network 192.168.2.1 0.0.0.0
#
#
interface Tunnel0/0/0
ospf network-type broadcast
ospf dr-priority 0
#
R3
#
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 10.1.1.3 0.0.0.0
network 192.168.3.1 0.0.0.0
#
#
interface Tunnel0/0/0
ospf network-type broadcast
ospf dr-priority 0
#
MGRE环境下的OSPF
文章来源地址https://www.toymoban.com/news/detail-717725.html
R4
#
ospf 1 router-id 4.4.4.4
area 0.0.0.0
network 10.1.2.2 0.0.0.0
network 192.168.4.1 0.0.0.0
#
#
interface Tunnel0/0/0
ospf network-type broadcast
#
R5
#
ospf 1 router-id 5.5.5.5
area 0.0.0.0
network 10.1.2.3 0.0.0.0
network 192.168.5.1 0.0.0.0
#
#
interface Tunnel0/0/0
ospf network-type broadcast
#
到了这里,关于MGRE环境下的OSPF的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!