【ACM竞赛入门】001.一文读懂常见的ACM题型输入输出格式

这篇具有很好参考价值的文章主要介绍了【ACM竞赛入门】001.一文读懂常见的ACM题型输入输出格式。希望对大家有所帮助。如果存在错误或未考虑完全的地方,请大家不吝赐教,您也可以点击"举报违法"按钮提交疑问。


本文通过各种类型的A+B题目来帮助大家快速了解ACM题目中常见的输入输出格式,帮助大家快速上手

A+B for Input-Output Practice (I)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b. Too easy?! Of course! I specially designed the problem for acm beginners. You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim

输入格式

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

1 5
10 20

样例输出

6
30

AC代码(C语言)文章来源地址https://www.toymoban.com/news/detail-734271.html

#include<stdio.h>

int main(){
	//freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (II)


时间限制: 1s 内存限制: 64MB

题目描述

The first line integer means the number of input integer a and b. Your task is to Calculate a + b.

输入格式

Your task is to Calculate a + b. The first line integer means the numbers of pairs of input integers.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

2
1 5
10 20

样例输出

6
30

AC代码(C语言)

#include<stdio.h>

int main(){
//	freopen("data.in.txt","r",stdin);
	int a,b,n;
	scanf("%d",&n);
	while(n--){	
		scanf("%d%d",&a,&b);
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (III)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b.

输入格式

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

1 5
10 20
0 0

样例输出

6
30

AC代码(C语言)

#include<stdio.h>

int main(){
//	freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		if(a==0&&b==0) break;	
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (IV)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate the sum of some integers.

输入格式

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

输出格式

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入

4 1 2 3 4
5 1 2 3 4 5
0

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,sum=0,tmp;
	while(~scanf("%d",&n)){
		sum=0;
		if(n==0) break;
		while(n--){
			scanf("%d",&tmp);
			sum+=tmp;
		}
		printf("%d\n",sum);
	}
	return 0; 
}

A+B for Input-Output Practice (V)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers.

输入格式

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

输出格式

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入

2
4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,m,sum=0,tmp;
	scanf("%d",&n);
	while(n--){
		sum=0;
		scanf("%d",&m);
		while(m--){
			scanf("%d",&tmp);
			sum+=tmp;
		}	
		printf("%d\n",sum);
	}

	return 0; 
}

A+B for Input-Output Practice (VI)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers.

输入格式

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

样例输入

4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,sum=0,tmp;
	while(~scanf("%d",&n)){
		sum=0;
		while(n--){
			scanf("%d",&tmp);
			sum+=tmp;
		}	
		printf("%d\n",sum);
	}

	return 0; 
}

A+B for Input-Output Practice (VII)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b.

输入格式

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

输出格式

For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.

样例输入

1 5
10 20

样例输出

6

30

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		printf("%d\n\n",a+b);
	}

	return 0; 
}

A+B for Input-Output Practice(VIII)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers

输入格式

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line

输出格式

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

样例输入

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

样例输出

10

15

6

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,m,tmp,sum=0;
	scanf("%d",&n);
	while(n--){
		sum=0;
		scanf("%d",&m);
		while(m--){
			scanf("%d",&tmp);
			sum+=tmp;
		}
		printf("%d\n\n",sum);
	}
	return 0; 
}

到了这里,关于【ACM竞赛入门】001.一文读懂常见的ACM题型输入输出格式的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处: 如若内容造成侵权/违法违规/事实不符,请点击违法举报进行投诉反馈,一经查实,立即删除!

领支付宝红包 赞助服务器费用

相关文章

  • 【数学建模竞赛】各类题型及解题方案

      建立评价指标-评价体系-同向化处理(都越多越好或越少越少)-指标无量纲处理  -权重- 主客观-合成 主客观概念主要是在 指标定权 时来划分的。主观评价与客观评价的区别是,主观评价算法在定权时主要以判断者的 主观经验为依据 ,而客观评价则主要基于 测量数据的基

    2024年02月10日
    浏览(41)
  • 【蓝桥杯备赛Java组】语言基础|竞赛常用库函数|输入输出|String的使用|常见的数学方法|大小写转换

    🎥 个人主页:深鱼~ 🔥收录专栏:蓝桥杯 🌄欢迎 👍点赞✍评论⭐收藏 目录 一、编程基础 1.1 Java类的创建  1.2 Java方法  1.3 输入输出  1.4 String的使用 二、竞赛常用库函数 1.常见的数学方法 2.大小写转换 前些天发现了一个巨牛的人工智能学习网站,通俗易懂,风趣幽默,

    2024年01月21日
    浏览(70)
  • 【蓝桥杯备赛Java组】第一章·语言基础|竞赛常用库函数|输入输出|String的使用|常见的数学方法|大小写转换

    🎥 个人主页:深鱼~ 🔥收录专栏:蓝桥杯 🌄欢迎 👍点赞✍评论⭐收藏 目录 一、编程基础 1.1 Java类的创建  1.2 Java方法  1.3 输入输出  1.4 String的使用 二、竞赛常用库函数 1.常见的数学方法 2.大小写转换 前些天发现了一个巨牛的人工智能学习网站,通俗易懂,风趣幽默,

    2024年01月19日
    浏览(72)
  • ACM模式(基础输入输出)

    Java方法间的调用 https://blog.csdn.net/m0_65627943/article/details/129214520

    2024年02月11日
    浏览(45)
  • 位运算【巧妙思路、两种常见题型】

    这里介绍两种代码中 位运算 非常常用的操作 例如说,我们需要计算11的第2位数。 11 = (1011) 2 我们常规思路就是将其转化为二进制数后,直接观察对应位置的值 这里需要注意的是第k位数指的是 从右开始 的第k位,即个位数是第一位 但是数字在计算机中都是直接以二进制数存

    2023年04月27日
    浏览(28)
  • ACM模式各种输入整理(C++)

    本文整理ACM模式的各种输入形式。 2.1.1 在终端的一行中输入 固定数目 的整型数字,并存到数组中,中间以 空格 分隔 示例: 3 1 2 3 方法1 方法2  方法3  正确性测试: 2.1.2 在终端的一行中输入 非固定数目 的整型数字,并存到数组中,中间以 空格(或者其他单字符,./) 分隔

    2024年02月02日
    浏览(38)
  • 华为OD机试ACM输入输出

    华为OD机考是基于牛客平台进行的,且必须采用ACM模式 ACM模式: 机试系统调用你的代码时,传入的都是字符串, 题目的输入描述 会说明字符串的组成规则,你需要根据这些规则从输入字符串中解析出需要的数据。 当算法程序计算出结果后,也不能直接返回给机试系统,因为

    2024年02月06日
    浏览(63)
  • [JAVA] ACM模式下输入输出

    经典十一道题 题一 多行数据,有行数限制,每行有个数限制 输入描述: 输入的第一行包括一个正整数t(1 = t = 100), 表示数据组数。 接下来 t 行, 每行一组数据。 每行的第一个整数为整数的个数n(1 = n = 100)。 接下来n个正整数, 即需要求和的每个正整数。 输出描述: 每组数据

    2024年02月13日
    浏览(35)
  • 【软考】案例/计算题型介绍及常见考点汇总

    一、案例/计算考试题型 系统集成项目管理工程师考试下午的科目为案例分析。其主要题型为计算题和案例问答题一共四道,偶尔会穿插判断、排序、填空类题型。

    2024年01月18日
    浏览(86)
  • ACM模式输入输出攻略 | C++篇

    大家好,这里是小黛~ 三月开始,就会陆续开启各大公司暑期实习的笔试和面试,而笔试中,ACM模式是必须要去 熟练掌握 的,今天就来针对ACM模式进行详细介绍。 这个系列首先以C++为例,进行ACM模式的讲解,后续会补齐JAVA、GO、JS等常用语言的输入输出案例。 本文主要介绍

    2024年02月02日
    浏览(44)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

博客赞助

微信扫一扫打赏

请作者喝杯咖啡吧~博客赞助

支付宝扫一扫领取红包,优惠每天领

二维码1

领取红包

二维码2

领红包