题目:
分析:
1.首先进行子网划分
2.创建环回接口,分配划分好的子网
3.用缺省路由完成第三题
4.用浮动静态路由完成第五题
第一步:根据广播域数量进行IP地址及网段的规划
因为网络中有15个局域网,但是R5的环回地址固定了,所以我们只需要划分出14个网段。
为了减少路由黑洞的出现并且加快传输的效率,对其中的某些网段进行了汇总,由于这里每个路由都是两个环回接口,所以这里不会产生路由黑洞了:
第二步:对这些路由器进行配置
要达到全网可达的需求,需要各个网段之间都能建立双向的连接,所以我们要对每个路由器中路由表中没有的信息进行配置。
R1
interface GigabitEthernet0/0/0
ip address 192.168.1.1 28
interface GigabitEthernet0/0/1
ip address 192.168.1.17 28
ip route-static 192.168.1.32 28 192.168.1.1
ip route-static 192.168.1.48 28 192.168.1.18
ip route-static 192.168.1.64 27 192.168.1.1
ip route-static 192.168.1.128 27 192.168.1.18
ip route-static 192.168.1.160 28 192.168.1.1
ip route-static 192.168.1.160 28 192.168.1.18
ip route-static 192.168.1.176 28 192.168.1.1
ip route-static 192.168.1.176 28 192.168.1.18
ip route-static 192.168.1.192 27 192.168.1.1
ip route-static 192.168.1.192 27 192.168.1.18
R2
interface GigabitEthernet0/0/0
ip address 192.168.1.2 28
interface GigabitEthernet0/0/1
ip address 192.168.1.33 28
ip route-static 192.168.1.16 28 192.168.1.1
ip route-static 192.168.1.48 28 192.168.1.34
ip route-static 192.168.1.96 27 192.168.1.1
ip route-static 192.168.1.128 27 192.168.1.1
ip route-static 192.168.1.128 27 192.168.1.34
ip route-static 192.168.1.160 28 192.168.1.34
ip route-static 192.168.1.176 28 192.168.1.34
ip route-static 192.168.1.192 27 192.168.1.34
R3
interface GigabitEthernet0/0/0
ip address 192.168.1.18 28
interface GigabitEthernet0/0/1
ip address 192.168.1.49 28
ip route-static 192.168.1.0 28 192.168.1.17
ip route-static 192.168.1.32 28 192.168.1.50
ip route-static 192.168.1.64 27 192.168.1.17
ip route-static 192.168.1.64 27 192.168.1.50
ip route-static 192.168.1.96 27 192.168.1.17
ip route-static 192.168.1.160 28 192.168.1.50
ip route-static 192.168.1.176 28 192.168.1.50
ip route-static 192.168.1.192 27 192.168.1.50
R4
interface GigabitEthernet0/0/0
ip address 192.168.1.50 28
interface GigabitEthernet0/0/1
ip address 192.168.1.34 28
interface GigabitEthernet0/0/2
ip address 192.168.1.177 28
interface GigabitEthernet4/0/0
ip address 192.168.1.161 28
ip route-static 192.168.1.0 28 192.168.1.33
ip route-static 192.168.1.16 28 192.168.1.49
ip route-static 192.168.1.64 27 192.168.1.33
ip route-static 192.168.1.96 27 192.168.1.33
ip route-static 192.168.1.96 27 192.168.1.49
ip route-static 192.168.1.128 27 192.168.1.49
R5
interface GigabitEthernet0/0/0
ip address 192.168.1.178 28
interface GigabitEthernet0/0/1
ip address 192.168.1.162 28
ip route-static 192.168.1.0 28 192.168.1.161
ip route-static 192.168.1.0 28 192.168.1.177
ip route-static 192.168.1.16 28 192.168.1.161
ip route-static 192.168.1.16 28 192.168.1.177
ip route-static 192.168.1.32 28 192.168.1.161
ip route-static 192.168.1.32 28 192.168.1.177
ip route-static 192.168.1.48 28 192.168.1.161
ip route-static 192.168.1.48 28 192.168.1.177
ip route-static 192.168.1.64 27 192.168.1.161
ip route-static 192.168.1.64 27 192.168.1.177
ip route-static 192.168.1.96 27 192.168.1.161
ip route-static 192.168.1.96 27 192.168.1.177
ip route-static 192.168.1.128 27 192.168.1.161
ip route-static 192.168.1.128 27 192.168.1.177
ip route-static 192.168.1.192 27 192.168.1.161
ip route-static 192.168.1.192 27 192.168.1.177
第三步:题目要求R1-R4上不能直接编写到达5.5.5.0/24网段的静态路由,但依然可以访问
所以,我们采用缺省路由的方法来实现,缺省路由是当查表时,若所有路由条目均无法匹配时将匹配 缺省路由。
在R1-R4上都配置一下缺省路由
R1
ip route-static 0.0.0.0 0.0.0.0 192.168.1.2
R2
ip route-static 0.0.0.0 0.0.0.0 192.168.1.34
R3
ip route-static 0.0.0.0 0.0.0.0 192.168.1.50
R4
ip route-static 0.0.0.0 0.0.0.0 192.168.1.162
第四步:环路问题的解决方法就是在黑洞路由器上配置一条指向汇总网段的空接口路由:
R1
interface LoopBack0
ip address 192.168.1.97 28
interface LoopBack1
ip address 192.168.1.113 28
配置简表
R2
interface LoopBack0
ip address 192.168.1.65 28
interface LoopBack1
ip address 192.168.1.81 28
配置简表
R3
interface LoopBack0
ip address 192.168.1.129 28
interface LoopBack1
ip address 192.168.1.145 28
配置简表
R4
interface LoopBack0
ip address 192.168.1.193 28
interface LoopBack1
ip address 192.168.1.209 28
配置简表
R5
interface LoopBack0
ip address 5.5.5.1 28
配置简表
第五步:R4和R5之间有两条线路,由于两条线路的传输速度并不相同,所以不能作为负载均衡来使用。但是可以作为备用线路使用,静态路由的优先级都是60,我们可以将100M的线路作为备用,通过将他的优先级降低为61来实现。
R5
ip route-static 192.168.1.0 255.255.255.240 192.168.1.177 preference 61
ip route-static 192.168.1.16 255.255.255.240 192.168.1.177 preference 61
ip route-static 192.168.1.32 255.255.255.240 192.168.1.177 preference 61
ip route-static 192.168.1.48 255.255.255.240 192.168.1.177 preference 61
ip route-static 192.168.1.64 255.255.255.224 192.168.1.177 preference 61
ip route-static 192.168.1.96 255.255.255.224 192.168.1.177 preference 61
ip route-static 192.168.1.128 255.255.255.224 192.168.1.177 preference 61
ip route-static 192.168.1.192 255.255.255.224 192.168.1.177 preference 61
测试:
全网可达
R1
R2
R3
R4
文章来源:https://www.toymoban.com/news/detail-788119.html
R5
文章来源地址https://www.toymoban.com/news/detail-788119.html
到了这里,关于eNSp静态路由综合练习的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!