陶陶摘苹果(升级版)
题目描述
又是一年秋季时,陶陶家的苹果树结了 n n n 个果子。陶陶又跑去摘苹果,这次他有一个 a a a 公分的椅子。当他手够不着时,他会站到椅子上再试试。
这次与 NOIp2005 普及组第一题不同的是:陶陶之前搬凳子,力气只剩下 s s s 了。当然,每次摘苹果时都要用一定的力气。陶陶想知道在 s < 0 s<0 s<0 之前最多能摘到多少个苹果。
现在已知 n n n 个苹果到达地上的高度 x i x_i xi,椅子的高度 a a a,陶陶手伸直的最大长度 b b b,陶陶所剩的力气 s s s,陶陶摘一个苹果需要的力气 y i y_i yi,求陶陶最多能摘到多少个苹果。
输入格式
第 1 1 1 行:两个数 苹果数 n n n,力气 s s s。
第 2 2 2 行:两个数 椅子的高度 a a a,陶陶手伸直的最大长度 b b b。
第 3 3 3 行~第 3 + n − 1 3+n-1 3+n−1 行:每行两个数 苹果高度 x i x_i xi,摘这个苹果需要的力气 y i y_i yi。
输出格式
只有一个整数,表示陶陶最多能摘到的苹果数。
样例 #1
样例输入 #1
8 15
20 130
120 3
150 2
110 7
180 1
50 8
200 0
140 3
120 2
样例输出 #1
4
提示
对于 100 % 100\% 100% 的数据, n ≤ 5000 n\leq 5000 n≤5000, a ≤ 50 a\leq 50 a≤50, b ≤ 200 b\leq 200 b≤200, s ≤ 1000 s\leq 1000 s≤1000, x i ≤ 280 x_i\leq 280 xi≤280, y i ≤ 100 y_i\leq 100 yi≤100。文章来源:https://www.toymoban.com/news/detail-831532.html
贪心经典要素:结构体排序文章来源地址https://www.toymoban.com/news/detail-831532.html
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 5e3 + 10;
struct Apple { //定义结构体,记录苹果的高度和体力花费
int height, cost;
}apple[N];
bool com(Apple aa, Apple bb) { //定义一个结构的排序方式,
return aa.cost < bb.cost; //使其sort时按照体力花费从小到大排序
}
// ! ! ! return < :从小到大 return > : 从大到小
int main() {
int n; cin >> n;
//s:体力,a:椅子高度,b:手伸长高度
int s, a, b; cin >> s >> a >> b;
//maxHeight = a+b
int res = 0; //存答案
for (int i = 1; i <= n; i++) {
cin >> apple[i].height >> apple[i].cost;
if (apple[i].cost == 0 && apple[i].height <= a+b) { //由于个别苹果摘得时候甚至能够只花0体力
res++; //故我们判断如果高度能够到且不用花费体力
apple[i].cost = 2e9; //就直接让答案增加,并且使这个苹果高度无限高
} //这样保证不会被重复搜到
}
sort(apple + 1, apple + n + 1, com);
for (int i = 1; i <= n; i++) {
if (a + b >= apple[i].height && s >= apple[i].cost) {//只需要判断最大高度能够到就可以,搬椅子不会花费额外体力
res++;
s -= apple[i].cost;
}
if (s <= 0)break; //如果体力已经没了就直接跳出
}
cout << res;
return 0;
}
到了这里,关于洛谷-P1478-陶陶摘苹果(升级版)(贪心)的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!