A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title -- a string of no more than 80 characters;
- Line #3: the author -- a string of no more than 80 characters;
- Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher -- a string of no more than 80 characters;
- Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found
instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
代码长度限制
16 KB
时间限制
1200 ms
内存限制文章来源:https://www.toymoban.com/news/detail-851962.html
64 MB文章来源地址https://www.toymoban.com/news/detail-851962.html
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
const int N = 10010;
int n;
int m;
struct st {
string id;
string title;
string author;
string words;
string publisher;
string year;
}q[N];
bool cmp(st a, st b) {
return a.id < b.id;
}
int main() {
cin >> n;
for (int i = 1; i <= n; i++) {
cin >> q[i].id;
getchar();
getline(cin, q[i].title);
getline(cin, q[i].author);
getline(cin, q[i].words);
getline(cin, q[i].publisher);
getline(cin, q[i].year);
}
sort(q + 1, q + 1 + n, cmp);
cin >> m;
for (int i = 1; i <= m; i++) {
int w;
char op;
string s;
cin >> w >> op;
getchar();
getline(cin, s);
if (w == 1) {
bool flag = false;
cout << w << op << " " << s << endl;
for (int i = 1; i <= n; i++) {
if (q[i].title == s) {
cout << q[i].id << endl;
flag = true;
}
}
if (!flag) cout << "Not Found" << endl;
}
if (w == 2) {
cout << w << op << " " << s << endl;
bool flag = false;
for (int i = 1; i <= n; i++) {
if (q[i].author == s) {
flag = true;
cout << q[i].id << endl;
}
}
if (!flag) cout << "Not Found" << endl;
}
if (w == 3) {
cout << w << op << " " << s << endl;
bool flag = false;;
for (int i = 1; i <= n; i++) {
if (q[i].words.find(s) !=-1) {
flag = true;
cout << q[i].id << endl;
}
}
if (!flag) cout << "Not Found" << endl;
}
if (w == 4) {
cout << w << op << " " << s << endl;
bool flag = false;
for (int i = 1; i <= n; i++) {
if (q[i].publisher == s) {
flag = true;
cout << q[i].id << endl;
}
}
if (!flag) cout << "Not Found" << endl;
}
if (w== 5) {
cout << w << op << " " << s << endl;
bool flag = false;
for (int i = 1; i <= n; i++) {
if (q[i].year == s) {
flag = true;
cout << q[i].id << endl;
}
}
if (!flag) cout << "Not Found" << endl;
}
}
return 0;
}
到了这里,关于pat甲级 1022 Digital Library的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!